The best place to ask programming/development questions, imo. UPDATE: stackoverflow is the *worst* place to *ask* questions (if your first question/comment doesn't get any up-rating/response, then u can't ask anymore questions--ridiculously unrealistic), but a great reference for finding answers.

My Music (Nickleus)

20120419

Failed to define class org.richfaces.renderkit.ComponentControlBehaviorRenderer in Module "deployment.myapp.ear:main" from Service Module Loader



when i started my jboss 7 in debug mode in eclipse indigo i would get the following error:
Failed to define class org.richfaces.renderkit.ComponentControlBehaviorRenderer in Module "deployment.myapp.ear:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/richfaces/renderkit/ComponentControlBehaviorRenderer (Module "deployment.myapp.ear:main" from Service Module Loader)

the error was that the richfaces jars were in the wrong folder, /lib
they should have been in /WebContent/WEB-INF/lib


Error getting reflective information for class X with ClassLoader Module, ClassNotFoundException: Y

i would get this error when i started my jboss 7 in debug mode in eclipse indigo:
11:02:38,727 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.deployment.subunit."myapp.ear"."richfaceswebapp.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.subunit."myapp.ear"."richfaceswebapp.war".POST_MODULE: Failed to process phase POST_MODULE of subdeployment "richfaceswebapp.war" of deployment "myapp.ear"
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_26]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_26]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_26]
Caused by: java.lang.RuntimeException: Error getting reflective information for class com.myapp.richfacesweb.tabledatahandlers.transportrequestlist.TransportRequestDataModel with ClassLoader ModuleClassLoader for Module "deployment.myapp.ear.richfaceswebapp.war:main" from Service Module Loader
at org.jboss.as.server.deployment.reflect.DeploymentReflectionIndex.getClassIndex(DeploymentReflectionIndex.java:70) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
at org.jboss.as.ee.metadata.MethodAnnotationAggregator.runtimeAnnotationInformation(MethodAnnotationAggregator.java:58)
at org.jboss.as.ee.component.deployers.InterceptorAnnotationProcessor.handleAnnotations(InterceptorAnnotationProcessor.java:85)
at org.jboss.as.ee.component.deployers.InterceptorAnnotationProcessor.processComponentConfig(InterceptorAnnotationProcessor.java:70)
at org.jboss.as.ee.component.deployers.InterceptorAnnotationProcessor.deploy(InterceptorAnnotationProcessor.java:55)
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
... 5 more
Caused by: java.lang.NoClassDefFoundError: LUIDataTable;
at java.lang.Class.getDeclaredFields0(Native Method) [rt.jar:1.6.0_26]
at java.lang.Class.privateGetDeclaredFields(Class.java:2291) [rt.jar:1.6.0_26]
at java.lang.Class.getDeclaredFields(Class.java:1743) [rt.jar:1.6.0_26]
at org.jboss.as.server.deployment.reflect.ClassReflectionIndex.<init>(ClassReflectionIndex.java:57) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
at org.jboss.as.server.deployment.reflect.DeploymentReflectionIndex.getClassIndex(DeploymentReflectionIndex.java:66) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
... 10 more
Caused by: java.lang.ClassNotFoundException: UIDataTable from [Module "deployment.myapp.ear.richfaceswebapp.war:main" from Service Module Loader]
at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
... 15 more
even though class X (TransportRequestDataModel) which called class Y (UIDataTable) were positioned correctly in the war hierarchy:
* richfaceswebapp.war/WEB-INF/classes/com/myapp/richfacesweb/tabledatahandlers/transportrequestlist/TransportRequestDataModel

* richfaceswebapp.war/WEB-INF/lib/richfaces-components-ui-4.2.1.Final.jar

i finally found out that i was getting the error because i had upgraded from richfaces 4.2.0.Final to 4.2.1.Final and i hadn't changed the build path in eclipse, so all i needed to do was edit the .classpath file to make sure it pointed to the correct jar version, i.e. 4.2.1.Final:

<classpathentry kind="lib" path="WebContent/WEB-INF/lib/richfaces-components-api-4.2.1.Final.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/richfaces-components-ui-4.2.1.Final.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/richfaces-core-api-4.2.1.Final.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/richfaces-core-impl-4.2.1.Final.jar"/>

20120412

can't browse repositories from svn root in eclipse - repository has been moved svn: repository moved permanently to X; please relocate


before you set up SVN, i suggest you read these 2 links below.

there's 2 ways to set up svn:
* 1 repository
* multiple repositories
http://subversion.apache.org/faq.html#multi-proj

here's a discussion about the pros and cons of each method:

when i tried to list the repos in eclipse's svn browser with the following url:
http://example.com/svn

i would get the following error:
error validating location: "org.tigris.subversion.javahl.ClientException: repository has been moved
svn: repository moved permanently to X; please relocate

this is because i chose method 2, multiple repositories, so svn isn't a repository, thus the error message is technically correct.


UPDATE 20131030

i ran into this same error today while trying to create a tag from trunk, like this:
svn copy https://example.com/repos/myrepo/trunk/ https://example.com/repos/myrepo/tags/20131029-nick-rich-extdt/ -m "almost got context menu for trq list working, but dan says to start with primefaces instead"

which gave this output:
svn: Repository moved permanently to 'https://example.com/repos/tc_inc2/'; please relocate


all i had to do to make it work was just change "repos" to "svn" (both are valid for browsing the repo, but it required that i used "svn":
svn copy https://example.com/svn/myrepo/trunk/ https://example.com/svn/myrepo/tags/20131029-nick-rich-extdt/ -m "almost got context menu for trq list working, but dan says to start with primefaces instead"


1 tip for faster internet browsing

set your DNS to use google's domain name servers

so what i did on ubuntu was this:
sudo nano -w /etc/dhcp/dhclient.conf

look for this line:

#supersede domain-name "fugue.com home.vix.com";

then directly below it, paste in this line:
supersede domain-name-servers 8.8.8.8,8.8.4.4;

restart networking (i just push the wireless button on my laptop off then on again, or you could pull out your cat5 internet cable and put it back into your computer again), then check to see that your change has taken effect:
sudo nano -w /etc/resolv.conf

you should see at least these 2 lines:

nameserver 8.8.8.8
nameserver 8.8.4.4

thanks to  Michael V. Antosha